Aba de desenvolvedor no Sitecore: O que é, e como habilitá-la?

No Sitecore há uma aba muito util na visão de editor de conteúdo(Content Editor), que por padrão vem desabilitada: Developer Tab(ou aba do desenvolvedor)

O que é a Developer Tab?
É uma aba que contém alguns atalhos para funcionalidades como, criação de templates, ir para a definição do template, serialização de itens, regeração de indices, entre outras, que são muito úteis ao implementar um website. Veja abaixo os botões da aba:
post1

Legal! Mas como posso habilitá-la?
É fácil. Clique com o botão direito do mouse na área cinza escura, onde as abas estão e clique em Developer, conforme mostra a figura abaixo:
post2

Quando você fizer isso verá que a aba Developer aparecerá ao lado da aba “My Toolbar”
post3

Aproveite!
Clique aqui para ver o mesmo post em inglês

Advertisements

Having issue starting the Coveo Search API service? This post might be useful

Are you installing Coveo and the Coveo Search API will not start? I had this problem and here is how I solved it.

THE PROBLEM

I have a Sitecore instance running locally and I was installing Coveo on premises for the first time locally. I had already installed all Coveo services and had updated the server section of my config.yml file to look like this:

Server:

uri: https://localhost:52810

serverCertificatePath: C:\CES7\Config\Certificates\cert-ca.pem

clientCertificatePath: C:\CES7\Config\Certificates\cert-iis.p12

But since I had not created the index just yet and this caused the service to not start properly. The error message I would get was “Windows could not start the Coveo Search API service on Local Computer”. Error 1067: The process terminated unexpectedly.

1

The same message would be captured on the Event Viewer so I thought that the next step would be to create the index.

THE SOLUTION
Here are 4 steps to fix this:

1- Open the Coveo Admin Tool(in my case http://localhost:8081) and I would get the Create Index form:

2

2- Open the Coveo Admin Tool(in my case http://localhost:8081) and I would get the Create Index form:

3

3- After pasting the license on the License field and clicking Apply Changes the Admin Tool Dashboard showed:

4.png

4- Now all I had to do was start the Coveo Search API service again and it would not stop:

5

After that I confirmed that Coveo for Sitecore was properly configured. To do that just access Sitecore’s control panel and look for Coveo’s Diagnostics Page:

6.png

Click here to see this post in portuguese

Instalando Coveo para Sitecore e o serviço Coveo Search API não inicia corretamente? Este post pode ser útil!

Você está instalando Coveo e o serviço Coveo Search API não inicia corretamente? Eu tive este problema e abaixo descrevo como foi  o resolvi.
O PROBLEMA
Eu tenho uma instância de Sitecore rodando local e instalei o Coveo neste ambiente pela primeira vez. Eu já havia instalado o Coveo Enterprise Search e o Coveo Search API. Após fazer isso eu atualizei a seção server do meu arquivo de configuração do Search API(config.yml) da seguinte forma:
server:
  uri: https://localhost:52810
  serverCertificatePath: C:\CES7\Config\Certificates\cert-ca.pem
  clientCertificatePath: C:\CES7\Config\Certificates\cert-iis.p12
Mas até então, eu ainda não havia criado o índice o que fazia com que o serviço não iniciasse corretamente. A Mensagem de erro que eu recebia era “Windows could not start the Coveo Search API service on Local Computer. Error 1067: The process terminated unexpectedly.”
1
Essa mesma mensagem estava sendo mostrada no Visualizador de Eventos do Windows então pensei que o próximo passo seria criar o índice.
A SOLUÇÃO
Seguem 4 passos para resolver este problema.
1- Abre a ferramenta de administração do Coveo(no meu caso rodando no endereço http://localhost:8081) e a tela de criar o índice apareceu:2
2- Depois de definir os caminhos de configurações, eu cliquei em Create Index e me foi solicitada a licença:
3
3- Após inserir a licença no campo e clicar em Apply Changes a tela de administração do Coveo apareceu:
4.png
4- Pronto! Agora a única coisa restante era iniciar o serviço Coveo Search API:
5
Após isso eu confirmei que o Coveo e o Sitecore estavam devidamente configurados. Para verificar isso, acesse o Sitecore e vá no Painel de Controle e procure pela página de diagnosticos do Coveo. Todos os estados devem estar verdes e rodando:

6.png

Clique aqui para ver o post em inglês