Ao atualizar, a interface do Sitecore parou de funcionar. Eis como eu resolvi esse problema.

Eis o cenário do post de hoje:

Você está fazendo o upgrade do Sitecore e depois que você finalizou o passos do upgrade, ao logar no Sitecore, você percebe que quando clica nos icones da interface do desktop ou do editor de conteúdo nada ocorre.

O que pode estar errado?

Eu tive este exato problema, ao fazer o upgrade da versão 8.0 update 3 para a versão 8.0 update 7. Ao buscar pela causa do problema, eu verifiquei nos logs do Sitecore e percebi que não haviam erros sendo lançados, porém havia uma mensagem de aviso, dizendo que havia uma configuração duplicada. No meu caso a mensagem era a seguinte:

9008 17:08:16 WARN  A duplicate setting “WebEdit.JQueryUIStylesheet” has been detected in the Sitecore.ExperienceEditor.config file. The value of the setting will be changed to “/sitecore/shell/Controls/Lib/jQuery/jQueryUI/1.10.3/smoothness/jquery-ui-1.10.3.min.css”.

O que eu fiz foi abrir a página do showconfig  (http://hostname/sitecore/admin/showconfig.aspx) e verifiquei por todas as referências a configuração WebEdit.JQueryUIStylesheet.

Eu vi ao fazer essa busca que haviam duas referências para essa configuração. Eu removi uma delas, que eu sabia que havia sido introduzida por engano, como parte do upgrade. Depois eu recarreguei o Sitecore e tudo voltou a funcionar normalmente.

Espero que essa dica seja útil para outros na tarefa de fazer o upgrade!

Para ver o mesmo post em inglês

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s